[libvoikko] libreoffice-voikko 3.2rc1

Harri Pitkänen hatapitk at iki.fi
Thu Feb 17 18:45:08 EET 2011

On Thursday 17 February 2011, Flammie Pirinen wrote:
> Ah, that doesn't seem nice. Not user friendly enough to scare lay
> users and not informative enough to help developers debug it.

Yes, this is exactly the same error you get on Windows if correct version of 
MSVC runtime is not installed or if there is anything whatsoever that happens 
to prevent loading the library.

> My guess
> is that since this is not the standalone version and I didn't include
> the linked libraries it might be needing them. I wonder if the
> libraries should be in the oxt file even in this version?

It might have been that the absolute path of libvoikko.dylib is encoded by 
default within the component library (voikko.dylib). So it won't be found even 
if you include libvoikko.dylib within the extension unless you fix that path 
or use a fixed installation location for libvoikko.dylib. See manual pages for 
otool and install_name_tool on how to change the path. I suspect that the 
solution is there if it can be solved at all, but I could not get it working 
when I tried that years ago.

Another thing is that if you build the extension on a given version of OS X it 
won't run on anything older than that. There is a way to fix that, you need to 
link against some older compatibility libraries that come with the operating 
system SDK. This probably needs to be done for both libvoikko and libreoffice-
voikko. I have never done that but it should be possible. Again otool will 
help you check what version of C/C++ runtime libraries are required to run the 
resulting library.


More information about the Libvoikko mailing list