[libvoikko] Is anyone still using libvoikko with Python < 2.6.5?

"Harri Pitkänen" hatapitk at iki.fi
Wed Apr 18 22:06:59 EEST 2012

Currently support for different Python versions in libvoikko is
implemented by writing the code for Python 2 and using the 2to3 utility to
convert the code to Python 3.

To make things easier to test I'd like to start using "from __future__
import unicode_literals" which would allow the use of untranslated code
for both major Python versions. This feature requires Python 2.6 and
apparently some bugs in the early 2.6.x will make it impossible to use
minor versions before 2.6.5.

I think that the default Python in OS X might be a problem. OS X 10.7 is
fine but 10.6 seems to ship with a bit too old default Python (2.6.1). It
does additionally have Python 3.0 though. Users of OS X 10.5 and earlier
would need to install Python from somewhere else.

I do not have a pressing need to make this change right now. So if someone
does still need older Pythons (and cannot easily update it), please let me
know and I'll postpone this transition to next year.


More information about the Libvoikko mailing list