[libvoikko] Changes to libreoffice-voikko for reliable (un)installation

Sjur Moshagen sjurnm at mac.com
Sat Aug 30 15:52:41 EEST 2014

30. aug. 2014 kl. 11:44 skrev Harri Pitkänen <hatapitk at iki.fi>:

> On Friday 29 August 2014 22:52:08 Sjur Moshagen wrote:
>> This is the big next issue for me: the LO 4.1 OXT does not work with neither
>> LO 4.2 or 4.3. It installs cleanly, but as soon as one opens the Voikko
>> preferences pane, it is completely empty (see attached screenshot). It
>> doesn’t help to build the OXT against the LO 4.2 or 4.3 SDK’s. The OXT is
>> built on MacOSX 10.6 to ensure backwards compatibility at least as far back
>> as that. And there is no issue with LO 4.1, which AFAIK uses the same API
>> as 4.2 and 4.3.
>> If we can fix this, we are a major step towards a release candidate.
> This is interesting... Since this works fine on Linux it must be specific to 
> the operating system or your configuration. There are some things that come to 
> my mind:
> - If you have previously disabled the grammar checker with 
> ENABLE_GRAMMAR_CHECKER=0 you might have problems with the latest release (it 
> cannot be completely disabled anymore).

This could be relevant, but I believe that the issue I see is much older than your recent change to the grammar checker settings.

Do I have to build libvoikko with grammar checker support with this change?

> - There are three OS X specific Makefile changes between 3.4.1 and current 
> master:
> * 53ed3ef52a12d89586db5ae58dab766a0223e063
> * 6d986e87eb6aec0874a0d96d808182e29e76d9d8
> * 2cf35173a9af66214983226d1af50967038fe559
> Could some of these have caused the problem? Try reverting these (one at a 
> time) and see if it helps.

I tested, and here is what I found:

* 53ed3ef52a12d89586db5ae58dab766a0223e063

This commit removed a shell script call to set the os platform correctly when building on macosx. When I reverted this patch, and updated the if tests to cover the actual output on the present system, nothing changed. The only file that could have changed was META-INF/manifest.xml, and it seems it gets the correct info anyway.

* 6d986e87eb6aec0874a0d96d808182e29e76d9d8

This commit removed the line:

nm -gx $^ | $(ADDSYMBOLS) >> build/voikko.map

from the macosx link stage. Since build/voikko.map can't be created anymore since LO 4.x (see the next commit), this line does not make any sense for the LO 4.x series (ie for building the trunk).

* 2cf35173a9af66214983226d1af50967038fe559

This change commented out the line:

		cat $(PRJ)/settings/component.uno.map > build/voikko.map

in the Makefile. The path $(PRJ)/settings/component.uno.map does not exist in any SDK in the 4.x series, and thus keeping or reverting this change does not make any sense.

* two changes are forced by changes in the 4.* SDK
* one has no effect

The bug must be related to something else.

> - Make sure you have installed matching versions of LibreOffice and 
> LibreOffice SDK when you build the extension. It is not sufficient to upgrade 
> or downgrade just the SDK.

I have both the application and the SDK installed in parallel with clearly marked version number appended to the names (and thus the paths), and I have tried to keep these things straight all the time. It is still possible of course that I have mixed up at some point, but I get the same result for building both with the 4.1, 4.2 and 4.3 SDK’s.

The build system is a macosx 10.6 with all patches, and my only changes to the settings (Makefile) are the path required to build a standalone version, and the list of (static) libraries to link in the link stage. Everything else should be as in trunk.


More information about the Libvoikko mailing list